Textpattern CMS support forum

You are not logged in. Register | Login | Help

#1 2019-02-08 12:16:44

gilibaus
Member
From: Milan, Italy
Registered: 2013-08-14
Posts: 55
Website

Cannot uninstall plugin

I have inadvertently installed etc_cache plugin (requires txp 4.6+) on my Textpattern 4.5.7 website. Now when I try to uninstall / delete it, I get this error:

Fatal error: Class ‘Txp’ not found in /home/mhd-01/www.mindfulnessbergamo.net/htdocs/textpattern/lib/txplib_misc.php(615) : eval()’d code on line 1

and the plugin does not get uninstalled.

Will someone please tell me what I should do to uninstall it?

Thanks.

Last edited by gilibaus (2019-02-08 13:31:53)

Offline

#2 2019-02-08 13:39:57

Bloke
Developer
From: Leeds, UK
Registered: 2006-01-29
Posts: 8,524
Website

Re: Cannot uninstall plugin

Easiest thing if you totally want to get rid of it is probably to do it directly in the database. Just visit the txp_plugin table and delete the etc_cache row, though it won’t tidy up after itself (which the plugin may do).

If you’re intending to install the 4.5.7-compatible version, you can just install it over the top of the incorrect version without deleting it first.


The smd plugin menagerie — for when you need one more gribble of power from Textpattern. Bleeding-edge code available on GitHub.

Txp Builders – finely-crafted code, design and Txp

Offline

#3 2019-02-08 14:05:22

etc
Developer
Registered: 2010-11-11
Posts: 3,043
Website

Re: Cannot uninstall plugin

I have answered by email, just in case. You should delete etc_cache table too, the plugin has no extra prefs.


etc_[ query | search | pagination | date | tree | cache ]

Offline

#4 2019-02-08 16:03:52

gilibaus
Member
From: Milan, Italy
Registered: 2013-08-14
Posts: 55
Website

Re: Cannot uninstall plugin

Thanks to all. No etc_cache table in the database, maybe the process aborted before creating it. As suggested by Bloke, I deleted the row in txp_plugin table and a few rows in txp_lang table. The database appears to be clean now.

@etc is there a 4.5.7-compatible version of your plugin?

Last edited by gilibaus (2019-02-08 16:06:01)

Offline

#5 2019-02-08 16:11:33

etc
Developer
Registered: 2010-11-11
Posts: 3,043
Website

Re: Cannot uninstall plugin

gilibaus wrote #316513:

@etc is there a 4.5.7-compatible version of your plugin?

Hmm, not sure. IIRC, the relevant callbacks were introduced in 4.6. This said, if you comment out the first line of the plugins code, it could partly work, but you’d need to refresh its cache manually.


etc_[ query | search | pagination | date | tree | cache ]

Offline

Board footer

Powered by FluxBB