Textpattern CMS support forum

You are not logged in. Register | Login | Help

#1 2018-05-10 08:50:24

gaekwad
Member
From: People's Republic of Cornwall
Registered: 2005-11-19
Posts: 2,379

Upgrading pre-4.2.0 versions Textpattern

tl;dr – upgrade pre-4.2.0 Textpattern to 4.2.0, then upgrade to the current version

I’ve been testing upgrade routes from current, old, and very old versions of Textpattern. In my testing (vanilla installs, no plugins, default content), it’s straightforward to upgrade from Textpattern 4.2.0 to the current version in one step. I’ve tested some — but not all — versions newer than 4.2.0 and did not encounter any issues.

Upgrading from versions before 4.2.0 — which was released in September 2009 — requires an additional step. If you’re running a very old pre-4.2.0 Textpattern instance, upgrade to 4.2.0 first, make sure all is well backstage, and then make the jump to a later version.

If you have plugins, check their current status before you start the process.

Installed Version First Upgrade Second Upgrade
<4.2.0 4.2.0 (download) 4.7 (download)
4.2.0 – 4.6.2 4.7 (download)

Whether you have plugins or not, take and check backups of your site and database. If you don’t want to mess around with the monster that is phpMyAdmin, I recommend Adminer if you want something server-side, and I also use SequelPro (Mac only) which is excellent.

Last edited by gaekwad (2018-08-02 09:58:04)

Offline

#2 2018-05-10 10:22:16

Bloke
Developer
From: Leeds, UK
Registered: 2006-01-29
Posts: 8,458
Website

Re: Upgrading pre-4.2.0 versions Textpattern

Excellent info, thanks Pete. Should this be sticky do you think?


The smd plugin menagerie — for when you need one more gribble of power from Textpattern. Bleeding-edge code available on GitHub.

Txp Builders – finely-crafted code, design and Txp

Offline

#3 2018-05-10 10:24:24

gaekwad
Member
From: People's Republic of Cornwall
Registered: 2005-11-19
Posts: 2,379

Re: Upgrading pre-4.2.0 versions Textpattern

Bloke wrote #311662:

Should this be sticky do you think?

Your call. It wouldn’t hurt, I suppose. There’re entries in README, HISTORY and elsewhere so this isn’t the only place to find it, and although there are pre-4.2.0 sites out there, they are few.

Offline

#4 2018-05-10 10:28:21

Bloke
Developer
From: Leeds, UK
Registered: 2006-01-29
Posts: 8,458
Website

Re: Upgrading pre-4.2.0 versions Textpattern

If we did sticky it, at release times we could update the table to reflect any changes that affect the number of hops required from various versions to the latest and greatest. Then if anything changes in future, we can highlight it here and make sure it’s seen.


The smd plugin menagerie — for when you need one more gribble of power from Textpattern. Bleeding-edge code available on GitHub.

Txp Builders – finely-crafted code, design and Txp

Offline

#5 2018-05-10 10:29:26

gaekwad
Member
From: People's Republic of Cornwall
Registered: 2005-11-19
Posts: 2,379

Re: Upgrading pre-4.2.0 versions Textpattern

Bloke wrote #311664:

If we did sticky it, at release times we could update the table to reflect any changes that affect the number of hops required from various versions to the latest and greatest.

Do it. I’ll reword it to be more generic.

Offline

#6 2018-05-10 11:18:25

uli
Moderator
From: Cologne
Registered: 2006-08-15
Posts: 4,152

Re: Upgrading pre-4.2.0 versions Textpattern

Thanks, Pete, for your thorough testing and for publishing the results!
Would your findings have helped in this case here, too? If so, you might want to amend your last post.


In bad weather I never leave home without wet_plugout, smd_where_used and adi_form_links

Offline

#7 2018-05-10 11:22:13

gaekwad
Member
From: People's Republic of Cornwall
Registered: 2005-11-19
Posts: 2,379

Re: Upgrading pre-4.2.0 versions Textpattern

uli wrote #311667:

Would your findings have helped in this case here, too? If so, you might want to amend your last post.

Ah, hindsight is a wonderful thing! I will update that reply, thanks for the reminder.

Offline

#8 2018-06-04 13:03:00

miles
Member
From: Plymouth
Registered: 2008-05-22
Posts: 72
Website

Re: Upgrading pre-4.2.0 versions Textpattern

Can we provide the link to 4.20 at the top? https://textpattern.com/weblog/336/textpattern-cms-420-released

Offline

#9 2018-06-04 13:46:33

philwareham
Core designer
From: Farnham, Surrey, UK
Registered: 2009-06-11
Posts: 3,093
Website

Re: Upgrading pre-4.2.0 versions Textpattern

miles wrote #312309:

Can we provide the link to 4.20 at the top?

Done. Thanks!

Offline

Board footer

Powered by FluxBB