Textpattern CMS support forum

You are not logged in. Register | Login | Help

#11 2017-11-24 08:54:01

jakob
Moderator
From: Germany
Registered: 2005-01-20
Posts: 3,159
Website

Re: many problems after server update by the hosting provider

It’s definitely an encoding problem. I see those character combinations in other situations too sometimes (I have a workflow for datamerging training course certificates from a spreadsheet file of course participants to Indesign, and I have to set MacRoman as the encoding in InDesign for the characters to come through properly … That’s on my machine only; I wouldn’t recommend that for an online site).

The only thing I can suggest is:

  • get consistent encoding working at all levels:
    • in config.php
    • in the database connection/collation (you can see and set that in database properties/settings in PHPMyAdmin or similar)
    • in each of your database table settings (there should be per-table settings)
    • (perhaps check your host’s settings too, if you have access to them)
  • Find out which characters – or character combinations – display properly for you on the front end and the back end through trial and error. That might even be the weird ones, though I hope not.
  • Apply that combination consistently throughout by either editing your articles (.ie., the long way) or searching and replacing your exported .sql file.


TXP Builders – finely-crafted code, design and txp

Offline

#12 2017-11-24 09:12:11

CeBe
Plugin Author
From: Caen - Fr
Registered: 2010-06-25
Posts: 344
Website

Re: many problems after server update by the hosting provider

GugUser wrote #307960:

After a server update one of my customer’s websites (it was still running with Textpattern 4.5.7) showed only question marks instead of umlauts.

I think it is related to this old bug.

I ran into this issue and had to patch textpattern/lib/txplib_db.php as Bloke said.

Offline

#13 2017-11-24 15:38:55

GugUser
Member
From: Quito (Ecuador)
Registered: 2007-12-16
Posts: 1,391

Re: many problems after server update by the hosting provider

Thanks, many thanks, CeBe, that was it. It seems to be solved after a lost working day.

Offline

#14 2017-11-24 15:55:45

GugUser
Member
From: Quito (Ecuador)
Registered: 2007-12-16
Posts: 1,391

Re: many problems after server update by the hosting provider

Thanks jakob too, for all the time you’ve taken to help me.

Offline

#15 2018-03-13 15:36:19

jayrope
Plugin Author
From: Berlin
Registered: 2006-07-06
Posts: 635
Website

Re: many problems after server update by the hosting provider

CeBe wrote #307973:

I think it is related to this old bug.

I ran into this issue and had to patch textpattern/lib/txplib_db.php as Bloke said.

Thanx for passing that tip on! Just changed from php 5.4 to php 7, all txp 4.6.2 installations on my server are messed up now. Will try above patch.


a hole turned upside down is a dome, though only when there’s gravity.

Offline

#16 2018-03-14 07:04:44

colak
Admin
From: Cyprus
Registered: 2004-11-20
Posts: 6,911
Website

Re: many problems after server update by the hosting provider

jayrope wrote #309929:

Thanx for passing that tip on! Just changed from php 5.4 to php 7, all txp 4.6.2 installations on my server are messed up now. Will try above patch.

Hi jayrope,
We are running txp 4.6.2 on PHP 7.0.28 without any problems. Would the problem be because of any plugins?


Yiannis
——————————
neme.org | hblack.net | LABS | State Machines | NeMe @ github

Offline

#17 2018-03-15 17:25:05

jayrope
Plugin Author
From: Berlin
Registered: 2006-07-06
Posts: 635
Website

Re: many problems after server update by the hosting provider

Colak, i patched my 4.6.2 versions now and they switched back to normal just like that. Took a little while, but was working well otherwise, a bit of extra info here.


a hole turned upside down is a dome, though only when there’s gravity.

Offline

Board footer

Powered by FluxBB