Textpattern CMS support forum

You are not logged in. Register | Login | Help

#1 2018-01-03 18:29:46

johnstephens
Plugin Author
From: Woodbridge, VA
Registered: 2008-06-01
Posts: 981
Website

Plugins known to be incompatible with Txp 4.7+?

Does anyone maintain a list of plugins known to be incompatible with Textpattern 4.7?

I’m beginning to test out the current 4.7 development build with a local clone of one of my more complex Textpattern sites, and I’ve begun running into problems. The first being wet_babble made this error appear on every front-end page:

Fatal error: Uncaught Error: Unsupported operand types in /var/www/public/textpattern/lib/txplib_misc.php(1803) : eval()’d code:16 Stack trace: #0 /var/www/public/textpattern/lib/txplib_misc.php(1803) : eval()’d code(19): wet_babble() #1 /var/www/public/textpattern/lib/txplib_misc.php(1803): eval() #2 /var/www/public/textpattern/publish.php(171): load_plugins() #3 /var/www/public/index.php(107): include(‘/var/www/public…’) #4 {main} thrown in /var/www/public/textpattern/lib/txplib_misc.php(1803) : eval()’d code on line 16

Disabling wet_babble resolved the problem.

I intend to comb through the site and identify any other problems I come across, but if there are any known problems with plugins in their current state, it would be great to know. And having a thread where known issues like this are collected might serve others as they upgrade their sites too.

Offline

#2 2018-01-03 23:45:16

phiw13
Plugin Author
From: Japan
Registered: 2004-02-27
Posts: 1,526
Website

Re: Plugins known to be incompatible with Txp 4.7+?

johnstephens wrote #308545:

Disabling wet_babble resolved the problem.

The good news there is you don’t need wet_babble on 4.7! language choice (for the admin side) per user is build in. mix-up, thanks Uli.

Incompatible plugins atm: glz_custom_fields – existing fields will continue to work (for now?) but creating and editing fields makes a mess. A few smd_ plugins had minor issues but those are fixed in their respective github repos.

Last edited by phiw13 (2018-01-04 01:38:20)

Offline

#3 2018-01-04 01:35:47

uli
Moderator
From: Cologne
Registered: 2006-08-15
Posts: 4,134

Re: Plugins known to be incompatible with Txp 4.7+?

phiw13 wrote #308549:

The good news there is you don’t need wet_babble on 4.7! language choice (for the admin side) per user is build in.

You mean wet_native, don’t you? (wet_babble is for customizing single strings.)


In bad weather I never leave home without wet_plugout, smd_where_used and adi_form_links

Offline

#4 2018-01-04 01:37:36

phiw13
Plugin Author
From: Japan
Registered: 2004-02-27
Posts: 1,526
Website

Re: Plugins known to be incompatible with Txp 4.7+?

uli wrote #308550:

You mean wet_native, don’t you? (wet_babble is for customizing single strings.)

Oops, sorry, you’re right. I mixed them up :-(

Offline

#5 2018-01-04 14:28:38

wet
Developer
From: Lenzing, Austria
Registered: 2005-06-06
Posts: 3,267
Website

Re: Plugins known to be incompatible with Txp 4.7+?

johnstephens wrote #308545:

Disabling wet_babble resolved the problem.

Thanks for the report. I’ve added a cautionary notice to the plugin download page to shy away unsuspecting users.

Offline

#6 2018-01-11 17:10:51

jpdupont
Member
From: Virton (BE)
Registered: 2004-10-01
Posts: 746
Website

Re: Plugins known to be incompatible with Txp 4.7+?

spf_codemirror : the settings no longer appear in the Textpattern settings window, making the plugin inoperative

—> With last 4.7 dev. Works with previous …

Last edited by jpdupont (2018-01-11 22:58:41)

Offline

#7 2018-01-11 22:50:56

uli
Moderator
From: Cologne
Registered: 2006-08-15
Posts: 4,134

Re: Plugins known to be incompatible with Txp 4.7+?

Dear core devs, is this topic at its current place of value for you or is the plugin discussion sub-forum the better place for it?


In bad weather I never leave home without wet_plugout, smd_where_used and adi_form_links

Offline

#8 2018-01-12 07:35:08

jpdupont
Member
From: Virton (BE)
Registered: 2004-10-01
Posts: 746
Website

Re: Plugins known to be incompatible with Txp 4.7+?

The plugin itself works fine if I type the expected parameters directly into the code. This is a problem directly related to the global $prefs that have been removed, and in the case of a new installation.

Offline

#9 2018-02-10 23:53:59

jakob
Moderator
From: Germany
Registered: 2005-01-20
Posts: 3,065
Website

Re: Plugins known to be incompatible with Txp 4.7+?

phiw13 wrote #308549:

Incompatible plugins atm: glz_custom_fields – existing fields will continue to work (for now?) but creating and editing fields makes a mess.

Has anyone had any success with this at all in 4.7.? If not, I can imagine this being an upgrade blocker for many people, and something we need to look at resolving collectively.

I recently tried Stef’s 1.5.0 modification* on a brand new txp v4.6.2 but couldn’t edit the fields.

BTW: Is there a compiled version of that beta?


TXP Builders – finely-crafted code, design and txp

Offline

#10 2018-02-11 00:44:30

johnstephens
Plugin Author
From: Woodbridge, VA
Registered: 2008-06-01
Posts: 981
Website

Re: Plugins known to be incompatible with Txp 4.7+?

jakob wrote #309180:

Has anyone had any success with this at all in 4.7.? If not, I can imagine this being an upgrade blocker for many people, and something we need to look at resolving collectively.

I can confirm, this issue has turned the upgrade from a no-brainer to a major tactical question for several sites I work on.

Offline

Board footer

Powered by FluxBB