Textpattern CMS support forum

You are not logged in. Register | Login | Help

#1 2017-11-14 16:20:44

tajloro
New Member
Registered: 2008-10-10
Posts: 8

[SOLVED] TXP Backend - No Input Field in article image field

I do not know how after the Textpattern 6.2.2 Upgrade the article image field has no input field (https://flic.kr/p/21u5wih). After i have done a new installation, no sucess! I had installed the glz_custom_fields v1.3.0 Plugin. Uninstalled, no sucess!

I refuse, what can I do. Thanks

Last edited by tajloro (Yesterday 18:52:12)

Offline

#2 2017-11-14 17:50:08

jakob
Moderator
From: Germany
Registered: 2005-01-20
Posts: 2,616
Website

Re: [SOLVED] TXP Backend - No Input Field in article image field

Hi, Three ideas:

  • Do you perhaps have bot_wtc (write tab customize) installed? Or any custom admin styling. If so, an older version may be conflicting with the new write tab layout.
  • Clear your browser cache, logout and login again in case an old version of textpattern.js is still be using from the earlier version.
  • Another thing to try: can you look at the source code (for example in a web inspector/developer toolbar, usually you can right-click on that part of the admin and choose inspect element or similar) and see if the input field is actually there but maybe not showing. It should look a little like this:

(Example using safari, right-click and “Element Informationen”, then selecting the element using the crosshair target tool). If you don’t see the actual field in the source, somethings moving it. If you do see it in the source code but it’s not visible on the page, look in the inspector to see if the css is hiding it somewhere.


TXP Builders – finely-crafted code, design and txp

Offline

#3 Yesterday 18:59:39

tajloro
New Member
Registered: 2008-10-10
Posts: 8

Re: [SOLVED] TXP Backend - No Input Field in article image field

Hi Jacob

Thanks for your three ideas.

It is the bot_image_upload plugin that causes the problems. If the plugin is turn, the text box will be visible!

Offline

#4 Yesterday 19:28:10

jakob
Moderator
From: Germany
Registered: 2005-01-20
Posts: 2,616
Website

Re: [SOLVED] TXP Backend - No Input Field in article image field

Glad I could be of help and good sleuthing for finding out. I guess it hides the article image field and replaces it with its image upload + display panel.

The admin panels have changed in more recent versions (= better and more consistent) but that also means that not all plugins hook in at the right place. Often they still actually work if you edit the plugin and re-hook them up to the right place where they are supposed to work. I can’t remember the exact situation with bot_image_upload, but there is an updated version that might work better for you.


TXP Builders – finely-crafted code, design and txp

Offline

Board footer

Powered by FluxBB