Textpattern CMS support forum

You are not logged in. Register | Login | Help

#1 2017-09-08 19:56:43

hicksdesign
New Member
Registered: 2017-09-08
Posts: 3

Plugins page missing in Admin (and not activating)

Hi folks! Since moving my site to a new server in May, I’m now trying to install new plugins and having a couple of issues.

1. In the admin panel, the ‘plugins’ page only offers to install new plugins. There is no interface for managing plugins
2. Plugins appear to install, but their relevant page in extensions doesn’t appear. Checking diagnostics it says that ‘All checks passed’ but the plugins I attempted to install aren’t listed in ‘active plugins’

It’s been a few years since I last installed a plugin, so it could be that they’re dealt with differently these days. Can anyone see what might be wrong?

Offline

#2 2017-09-08 21:11:16

Bloke
Developer
From: Leeds, UK
Registered: 2006-01-29
Posts: 7,682
Website

Re: Plugins page missing in Admin (and not activating)

Hmmmm. Nothing fundamental has changed with the plugin installation process. Still upload the .txt file, install, activate, done. If all checks passed and the high diagnostics panel shows no issues I’m at a loss.

If your plugins panel is banjaxed, it does sound like a server issue. What version of Textpattern do you have installed and what’s your server environment (PHP / MySQL versions, etc)? And what plugins/versions are you attempting to install?

If you can (perhaps temporarily) stick your site in Debugging mode from the Admin->Prefs panel and try to view the Plugins panel, then attempt installation of one of the plugins in question, that might give some clues while the error suppression is off.


The smd plugin menagerie — for when you need one more gribble of power from Textpattern. Bleeding-edge code available on GitHub.

Txp Builders – finely-crafted code, design and Txp

Offline

#3 2017-09-09 17:31:34

hicksdesign
New Member
Registered: 2017-09-08
Posts: 3

Re: Plugins page missing in Admin (and not activating)

Ah, good plan! With debug mode I get the following errors:

User_Error “Illegal mix of collations (utf8_general_ci,COERCIBLE) and (latin1_swedish_ci,IMPLICIT) for operation ‘strcmp’”
in /server/path/to/textpattern/lib/txplib_db.php at line 409.

and the following output…

adminErrorHandler()
textpattern/lib/txplib_db.php:409 trigger_error()
textpattern/lib/txplib_db.php:1126 safe_query()
textpattern/lib/txplib_db.php:975 startRows()
textpattern/include/txp_plugin.php:109 safe_rows_start()
textpattern/include/txp_plugin.php:52 plugin_list()
textpattern/index.php:211 include()

My server is running Apache 2.4.27, PHP 5.6.31, MySQL 10.1.26-MariaDB

Offline

#4 2017-09-09 20:33:29

philwareham
Core designer
From: Farnham, Surrey, UK
Registered: 2009-06-11
Posts: 2,755
Website

Re: Plugins page missing in Admin (and not activating)

I wonder if Ruud’s plugin here could fix the collation problem by making collation for everything consistently utf8mb4.

You can use something like Sequel Pro to amend the database collation per table too but I’d definitely try that in a local install to test it.

Offline

#5 2017-09-10 09:30:46

Bloke
Developer
From: Leeds, UK
Registered: 2006-01-29
Posts: 7,682
Website

Re: Plugins page missing in Admin (and not activating)

Aha! Best bet then for illegal mix of collations is Robert’s advice. Change the collation mentioned in the command if it differs from your setup in other tables, but that’s the collation most people use.

Hope it helps.


The smd plugin menagerie — for when you need one more gribble of power from Textpattern. Bleeding-edge code available on GitHub.

Txp Builders – finely-crafted code, design and Txp

Offline

#6 2017-09-10 18:45:19

hicksdesign
New Member
Registered: 2017-09-08
Posts: 3

Re: Plugins page missing in Admin (and not activating)

Perfect! I couldn’t install Ruud’s plugin, but the SQL query Robert posted sorted me out! Thanks very much for your help – I couldn’t have done this without you! :)

Offline

Board footer

Powered by FluxBB