Textpattern CMS support forum

You are not logged in. Register | Login | Help

#1 2009-12-17 11:43:02

wet
Developer
From: Lenzing, Austria
Registered: 2005-06-06
Posts: 3,267
Website

wet_native: Per-user admin-side language settings

********************************

This plugin is now part of Textpattern core as of Txp 4.7.0 and higher. Users can visit the Admin->Languages panel to set their admin-side language experience from those languages installed by the site administrator.

********************************

wet_native lets publishers assign a distinct admin-side language to each registered user.

Documentation and download.

Last edited by Bloke (2019-03-09 15:22:12)

Offline

#2 2010-02-15 00:52:19

bici
Member
From: vancouver
Registered: 2004-02-24
Posts: 1,438
Website

Re: wet_native: Per-user admin-side language settings

lovely plugin. just installed it for my italian friend. millie grazie


…. texted postive

Offline

#3 2010-02-15 01:04:44

maniar
Member
From: Hamilton, Ontario
Registered: 2010-01-04
Posts: 66
Website

Re: wet_native: Per-user admin-side language settings

W00T I just downloaded and installed it – it’s awesomely useful ! (Get it into core ;-) Thanks !


اردو میں بھی دستیاب Textpattern آپ کے لیے اب

Offline

#4 2013-05-15 05:23:27

bici
Member
From: vancouver
Registered: 2004-02-24
Posts: 1,438
Website

Re: wet_native: Per-user admin-side language settings

Hi i just noticed these error message.

Strict Standards: call_user_func_array() expects parameter 1 to be a valid callback, non-static method wet_native::run() should not be called statically in /users/home/giovanni/domains/milano.consolatotanzania.org/web/public/textpattern/lib/txplib_misc.php on line 854
Strict Standards: Non-static method wet_native::_lang() should not be called statically in /users/home/giovanni/domains/milano.consolatotanzania.org/web/public/textpattern/lib/txplib_misc.php(812) : eval()'d code on line 90 p.

i am running Textpattern version: 4.5.4 .

this is happening on two different sites.


…. texted postive

Offline

#5 2013-05-16 09:13:38

wet
Developer
From: Lenzing, Austria
Registered: 2005-06-06
Posts: 3,267
Website

Re: wet_native: Per-user admin-side language settings

Thanks for the report. Please try wet_native v0.4.

Offline

#6 2013-05-16 21:27:58

bici
Member
From: vancouver
Registered: 2004-02-24
Posts: 1,438
Website

Re: wet_native: Per-user admin-side language settings

wet wrote:

Thanks for the report. Please try wet_native v0.4.

Much better ;-)

Thank-you


…. texted postive

Offline

#7 2016-03-03 08:15:06

phiw13
Plugin Author
From: Japan
Registered: 2004-02-27
Posts: 1,625
Website

Re: wet_native: Per-user admin-side language settings

Activating this on a reasonably virginal 4.6dev install, then going to the Users panel gives me a truckload of errors (debug mode):

Notice "Undefined index: query"
in /Users/username/Sites/_txp/textpattern/lib/class.trace.php at line 69.
textpattern/lib/class.trace.php:69 adminErrorHandler()
textpattern/lib/txplib_misc.php:1919 Trace->stop()
textpattern/lib/txplib_head.php:142 callback_event()
textpattern/include/txp_admin.php:301 pagetop()
textpattern/include/txp_admin.php:60 author_list()
textpattern/index.php:211 include()

There are more… The whole page is basically a litany of errors.

Offline

#8 2016-03-04 05:05:51

wet
Developer
From: Lenzing, Austria
Registered: 2005-06-06
Posts: 3,267
Website

Re: wet_native: Per-user admin-side language settings

This issue should be fixed. Please pull here.

Offline

#9 2016-03-04 06:35:25

phiw13
Plugin Author
From: Japan
Registered: 2004-02-27
Posts: 1,625
Website

Re: wet_native: Per-user admin-side language settings

wet wrote #298145:

This issue should be fixed. Please pull here.

Yup, now I can access the Users panel perfectly. Thanks.

PS – you may still want to update the plugin to add the new layout class (.txp-form-field) on the wrapping div.

Or is that the job of Textpattern core?

Last edited by phiw13 (2016-03-04 06:35:40)

Offline

#10 2017-07-30 14:48:31

whocarez
Plugin Author
From: Germany/Ukraine
Registered: 2007-10-08
Posts: 250
Website

Re: wet_native: Per-user admin-side language settings

after upgrading to 4.6.2 in debug mode I got the following error messages:

2048 "call_user_func_array() expects parameter 1 to be a valid callback, non-static method wet_native::run() should not be called statically"
in /var/www/site/textpattern/lib/txplib_misc.php at line 1895.

adminErrorHandler()
textpattern/lib/txplib_misc.php:1895 call_user_func_array()
textpattern/lib/txplib_head.php:124 callback_event()
textpattern/include/txp_prefs.php:164 pagetop()
textpattern/include/txp_prefs.php:144 prefs_list()
textpattern/include/txp_prefs.php:49 prefs_save()
textpattern/index.php:211 include()

2048 "Non-static method wet_native::_lang() should not be called statically"
in /var/www/site/textpattern/lib/txplib_misc.php(1782) : eval()'d code at line 90.

textpattern/lib/txplib_misc.php(1782) : eval()'d code:90 adminErrorHandler()
textpattern/lib/txplib_misc.php(1782) : eval()'d code:90 wet_native::_lang()
wet_native::run()
textpattern/lib/txplib_misc.php:1895 call_user_func_array()
textpattern/lib/txplib_head.php:124 callback_event()
textpattern/include/txp_prefs.php:164 pagetop()
textpattern/include/txp_prefs.php:144 prefs_list()
textpattern/include/txp_prefs.php:49 prefs_save()
textpattern/index.php:211 include()

Offline

Board footer

Powered by FluxBB