Textpattern CMS support forum

You are not logged in. Register | Login | Help

#1 2017-01-02 12:13:05

alexandra
Member
From: Cologne, Germany
Registered: 2004-04-02
Posts: 1,370

Update from 4.0.8 to latest

Hello all,
i was asked to update a website running still on Txp 4.0.8 to the latest Txp version as the hoster updates php version to php 5.7. Current php version is 5.217.
As i am not familiar with TXP anymore, i wonder if this is possible in one step or rather not advisable?
Which is the smoothest way else?
Thanks for any advise … and btw Happy New Year

Offline

#2 2017-01-02 15:39:23

philwareham
Core designer
From: Farnham, Surrey, UK
Registered: 2009-06-11
Posts: 2,806
Website

Re: Update from 4.0.8 to latest

You should be able to directly update from 4.0.8 to 4.6.2 (although minimum PHP require is 5.3.3 for that, so you’d want to make sure PHP is updated at same time).

Offline

#3 2017-01-02 18:17:04

wet
Developer
From: Lenzing, Austria
Registered: 2005-06-06
Posts: 3,265
Website

Re: Update from 4.0.8 to latest

alexandra wrote #303465:

Hello all,

She’s alive!

Offline

#4 2017-01-03 07:57:15

Dragondz
Moderator
From: Algérie
Registered: 2005-06-12
Posts: 1,264
Website

Re: Update from 4.0.8 to latest

wet wrote #303468:

She’s alive!

he is alive!

Offline

#5 2017-01-03 09:01:48

colak
Admin
From: Cyprus
Registered: 2004-11-20
Posts: 6,222
Website

Re: Update from 4.0.8 to latest

Hey alexandra,

good to see you! Hope all is well and that we’ll be seeing you more often here.


Yiannis
——————————
neme.org | hblack.net | LABS | NeMe @ github

Offline

#6 2017-01-03 11:31:25

gaekwad
Member
From: North Cornwall, UK
Registered: 2005-11-19
Posts: 2,002

Re: Update from 4.0.8 to latest

For completeness, there have been many changes since 4.0.8 and some plugins intended for 4.0.8 don’t play well with 4.6.0, so while a vanilla 4.0.8 to 4.6.2 should be OK, some plugin due diligence would be sensible.

Are any plugins installed? If so, what versions? Check /textpattern/index.php?event=diag for a list of plugins and their versions.

Offline

#7 2017-01-03 13:56:14

alexandra
Member
From: Cologne, Germany
Registered: 2004-04-02
Posts: 1,370

Re: Update from 4.0.8 to latest

Hello all, hello wet and colak,
you are still around :) nice to see you here, indeed a long time… hope you´re all doing fine.

Thx as well for the answer philw and gaekwad .. it is the site of a german journalist and pretty simple, no ‘complex’ plugins. The server php will be updated by end of January. Currently I could switch to php cgi/fpm 5.5 5.6. and 7 but not sure this is okay. As i am not familiar with this all anymore, i wonder if anybody of you like the job? It is paid. The site is really simple but in german, server language too. Send me a message if you are interested.

Offline

#8 2017-01-03 14:51:47

gaekwad
Member
From: North Cornwall, UK
Registered: 2005-11-19
Posts: 2,002

Re: Update from 4.0.8 to latest

alexandra wrote #303474:

As i am not familiar with this all anymore, i wonder if anybody of you like the job? It is paid. The site is really simple but in german, server language too. Send me a message if you are interested.

At the risk of being unhelpful or That Guy, you might find this forum to be helpful.

Moderators: perhaps a thread relocation to that forum might be appropriate?

Offline

#9 2017-01-03 16:09:16

Els
Admin
From: The Netherlands
Registered: 2004-06-06
Posts: 7,456

Re: Update from 4.0.8 to latest

gaekwad wrote #303475:

Moderators: perhaps a thread relocation to that forum might be appropriate?

Done!

Offline

Board footer

Powered by FluxBB