Textpattern CMS support forum

You are not logged in. Register | Login | Help

#71 2013-03-04 23:26:46

Bloke
Developer
From: Leeds, UK
Registered: 2006-01-29
Posts: 8,620
Website

Re: bot_privs: edit user level privileges

Avant La Lettre wrote:

No offense to Stef

None taken. smd_user_manager is completely over the top for many applications, but for some it’s damn handy (ahem, when it works, unlike in the current 4.6-dev, meh). So I consider bot_privs very much a useful plugin. In fact, we’ve just used it in a site that went live last week.

And, yes, the list ID has been dropped from the CSS and core in 4.5.x, replacing it with the more useful txp-list class instead. As a general rule, any table that displays icky in 4.5.x can have that same sort of patch applied.

Last edited by Bloke (2013-03-04 23:30:43)


The smd plugin menagerie — for when you need one more gribble of power from Textpattern. Bleeding-edge code available on GitHub.

Txp Builders – finely-crafted code, design and Txp

Offline

#72 2013-03-05 00:03:50

Avant La Lettre
Member
From: Zurich, Switzerland
Registered: 2011-10-03
Posts: 3
Website

Re: bot_privs: edit user level privileges

OMG, you’re right!!
startTable('','','txp-list') just cleaned up all display errrors in rss_admin_db_manager (Uli’s version) for me, too.

Thank you so much for sharing this eye-opener.

Last edited by Avant La Lettre (2013-03-05 00:05:01)

Offline

#73 2016-09-16 05:23:33

colak
Admin
From: Cyprus
Registered: 2004-11-20
Posts: 7,151
Website

Re: bot_privs: edit user level privileges

hi all,

Does anybody know if this plugin is working with txp v4.6?


Yiannis
——————————
neme.org | hblack.net | LABS | State Machines | Respbublika! | NeMe @ github

Offline

#74 2016-09-16 07:07:52

colak
Admin
From: Cyprus
Registered: 2004-11-20
Posts: 7,151
Website

Re: bot_privs: edit user level privileges

I just created a dev site to check this plugin which returns the following errors

After installing and enabling I went to extensions>bot_bot_privs where I get the message: bot_privs is not yet properly initialized. Use the button below to create the preferences table.

I clicked Install which returned

Warning "mysql_get_server_info(): Access denied for user ''@'localhost' (using password: NO)".

clicking OK returns

Warning "mysql_get_server_info(): A link to the server could not be established".

another OK clicked:

User_Error "You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'TYPE=MyISAM' at line 5".

here is what I think are the relevant diagnostics:

Textpattern version: 4.6.0 (86d82f868a753eb919f2250d82f4dcae)
Last update: 2016-09-11 05:34:10/2016-09-16 06:54:27
PHP version: 5.6.25
GD Graphics Library: bundled (2.1.0 compatible); supported formats: GIF, JPG, PNG.
Server TZ: UTC
MySQL: 5.5.32-cll-lve
Locale: en_GB.UTF-8
Server: Apache
PHP server API: cgi-fcgi
RFC 2616 headers: 0

Yiannis
——————————
neme.org | hblack.net | LABS | State Machines | Respbublika! | NeMe @ github

Offline

#75 2016-11-23 17:46:00

jakob
Admin
From: Germany
Registered: 2005-01-20
Posts: 3,388
Website

Re: bot_privs: edit user level privileges

A slight tangent to this thread:

I made some minor updates to Jukka’s rah_privileges for Textpattern v4.6 – which addresses the same functionality as bot_privs – and compiled txt installer packages for it.

It seems to work okay on v 4.6 based on my own basic testing. If you’re willing to try it out, you can find the installer packages here.


TXP Builders – finely-crafted code, design and txp

Offline

Board footer

Powered by FluxBB