Textpattern CMS support forum

You are not logged in. Register | Login | Help

#51 2007-07-26 12:56:27

hachi
Member
From: switzerland
Registered: 2004-04-24
Posts: 25

Re: [plugin] [ORPHAN] chh_related_articles

Hi. I used to use this plugin with TxP version 4.0.4. It stopped working after I upgraded to 4.0.5. Has anybody got it working in version 4.0.5? Is the author still developing it actively? Or is there a similar plugin which does the same?
Any help appreciated.
Oliver

Last edited by hachi (2007-07-26 12:57:34)

Offline

#52 2007-07-26 15:46:06

uli
Moderator
From: Cologne
Registered: 2006-08-15
Posts: 3,964

Re: [plugin] [ORPHAN] chh_related_articles

Have you tried to modify the plugin as I mentioned in post #50? Could be a possibility to get it working.


In bad weather I never leave home without wet_plugout, smd_where_used and adi_form_links

Offline

#53 2007-07-27 07:26:29

hachi
Member
From: switzerland
Registered: 2004-04-24
Posts: 25

Re: [plugin] [ORPHAN] chh_related_articles

No. I tried both versions of the solution but they didn’t work. I get the following errors in Testing mode:

tag_error <txp:chh_related_articles relation="title->keywords" section="releases" sortby="custom_2" sortdir="asc" wraptag="ul" break="li" class="related" label="&#9835; Related releases" labeltag="h4" /> ->  Textpattern Notice: Unknown tag attribute: section  on line 605

Obviously, Textpattern doesn’t recognize one attribute from the tag. I don’t know any PHP so I’m lost here. And I’m developing locally on my Mac with PHP 4.

Last edited by hachi (2007-07-27 07:39:04)

Offline

#54 2007-07-27 07:53:12

hachi
Member
From: switzerland
Registered: 2004-04-24
Posts: 25

Re: [plugin] [ORPHAN] chh_related_articles

I get around 28 errors of the same kind on one page. But now I noticed that it seems to work all the same since I get the correct outputs. Strangely, on one page (section), it seems to work but not in the other. The working one has the relation set to “custom_1”, in the other (working) one, the relation is set to “title->keywords”. Very strange.

Last edited by hachi (2007-07-27 07:58:20)

Offline

#55 2007-07-27 13:02:18

uli
Moderator
From: Cologne
Registered: 2006-08-15
Posts: 3,964

Re: [plugin] [ORPHAN] chh_related_articles

Try this: turn off chh_related_article, see if there are further errors, eliminate them, then switch chh back on.
I had handmade errors that increased chh’s susceptibility. It ran properly (though with a whole novel of error reports) when I had eliminated my own faults. (nevertheless: it was 4.0.4, not 4.0.5)


In bad weather I never leave home without wet_plugout, smd_where_used and adi_form_links

Offline

#56 2007-07-27 14:01:38

hachi
Member
From: switzerland
Registered: 2004-04-24
Posts: 25

Re: [plugin] [ORPHAN] chh_related_articles

Problem is, it used to work perfectly for me in 4.0.4.

But as you suggested, I eliminated all errors, switched off all other plugins (ob1_title, rss_admin_show_adv_opts, jnm_audio) and still get errors like these:

tag_error <txp:chh_related_articles relation="title->keywords" section="releases" sortby="custom_2" sortdir="asc" wraptag="ul" break="li" class="related" labeltag="h4" /> ->  Textpattern Notice: Unknown tag attribute: section  on line 605
textpattern/lib/txplib_misc.php:605 trigger_error()
textpattern/lib/txplib_misc.php(534) : eval()'d code:191 latts()
textpattern/lib/txplib_misc.php(534) : eval()'d code:184 chh_build_article_list()
textpattern/publish.php:963 chh_related_articles()
processtags()
textpattern/publish.php:922 preg_replace_callback()
textpattern/lib/txplib_misc.php:1383 parse()
textpattern/publish.php:704 parse_form()
textpattern/publish.php:808 doarticles()
textpattern/publish.php:798 parsearticles()

Notice this line:

Textpattern Notice: Unknown tag attribute: section  on line 605

I get the above error once for every attribute available in chh_related_article (section, sortby, sortdir, label, break, wraptag, etc.). Not only for those I use in my particular case.

…And to add a little more to the fun: I don’t get any errors in the section the plugin doesn’t work at all and displays nothing. It just fails silently.

Last edited by hachi (2007-07-27 14:37:05)

Offline

#57 2007-07-27 14:37:45

uli
Moderator
From: Cologne
Registered: 2006-08-15
Posts: 3,964

Re: [plugin] [ORPHAN] chh_related_articles

I get the above error once for every attribute available

That’s what I meant with »novel« ;)
Sorry I couldn’t help you any further. I have no PHP expertise, I’ve only managed to sort out my own troubles with this plugin.
Good luck!
BTW, if you get to solve your troubles, be so kind to post your solution here, will you?


In bad weather I never leave home without wet_plugout, smd_where_used and adi_form_links

Offline

#58 2007-07-27 14:43:12

hachi
Member
From: switzerland
Registered: 2004-04-24
Posts: 25

Re: [plugin] [ORPHAN] chh_related_articles

Yeah sure, I will. Danke für die Hilfe ;-)

Offline

#59 2007-09-18 17:06:03

kemie
Plugin Author
From: mexico<-->sweden
Registered: 2004-05-20
Posts: 495
Website

Re: [plugin] [ORPHAN] chh_related_articles

did you guys manage to find a solution?


~~~~~~~~~~~~~| monolinea.com | pixilate.com | istockphoto.com/kemie |~~~~~~~~~~~~~

Offline

#60 2007-09-18 17:40:38

hachi
Member
From: switzerland
Registered: 2004-04-24
Posts: 25

Re: [plugin] [ORPHAN] chh_related_articles

no. unfortunately not. the original developer seems not to be continueing the plugin. maybe someone else might want to jump in?

Last edited by hachi (2007-09-18 17:40:52)

Offline

Board footer

Powered by FluxBB