Textpattern CMS support forum

You are not logged in. Register | Login | Help

#1 2006-09-12 11:18:35

de4ths0n
New Member
Registered: 2006-09-04
Posts: 3

"Previous" and "Newest" not working

Hi;

I’ve a textpattern installed with 12 sections, and it seems to work properly, but i’m not able to set the “previous” and “newest” buttons at the end of each different section.

The code to every section is:

<code>
<txp:article_custom form=“default” limit=“10” section=“sectionname” sortby=“Posted” sortdir=“desc” author=“malize” listform=“default” />
</code>
<br>
And i’ve tried to add

<code>
<txp:if_article_list>
<p>
<txp:older>Previous</txp:older>
<txp:newer>Next</txp:newer>
</p>
</txp:if_article_list>
</code>
<br>
to each diferent section code also, but is not working at all, the buttons doesn’t appear.

anybody could help me?

thanks and sorry about my poor english.

Offline

#2 2006-09-12 12:51:08

Mary
Sock Enthusiast
Registered: 2004-06-27
Posts: 6,236

Re: "Previous" and "Newest" not working

Navigation tags do not work for article_custom – its purpose to output exactly 1 straight list, no pagination, etc.

A plugin like chh_article_custom is probably what you want. Is this part absolutely necessary? author="malize" Because, if it isn’t, you don’t need to use article_custom anyway.

Last edited by Mary (2006-09-12 18:22:58)

Offline

#3 2006-09-12 15:33:13

de4ths0n
New Member
Registered: 2006-09-04
Posts: 3

Re: "Previous" and "Newest" not working

really thank you Mary : )

Offline

#4 2006-10-05 18:32:44

minusf
Member
Registered: 2005-02-15
Posts: 104

Re: "Previous" and "Newest" not working

hi there,

i was just bitten by this same philosophical dichotomy.

i think i am missing something here, becasue i think i need
custom_articles on my main page so i can narrow down the displayed
articles to a certain category:

<code><txp:article_custom limit=“10” category=“news” sortby=“Posted” sortdir=“desc” form=“news” /></code>

.
i want to have only “news” category articles on my main page.

also, my “Permanent link mode” is “/title”, so there is no context for txp:article
to base the article category on, or is there?

if there is a better way to get this done, what is it?


we is experts™

Offline

#5 2006-10-05 21:40:56

minusf
Member
Registered: 2005-02-15
Posts: 104

Re: "Previous" and "Newest" not working

ok :) i think i have found a way.
finally i understand what is “display on front page”
for in the section config :)

i set all the articles to section “news” and made only this section
display on the front page. txp_joy :)

so i converted my article_custom to article.

but see my next thread about making txp:newer, txp:older conditional :)


we is experts™

Offline

Board footer

Powered by FluxBB