Textpattern CMS support forum

You are not logged in. Register | Login | Help

#11 2005-08-21 11:39:46

peterj
Member
From: Melbourne, Australia
Registered: 2005-06-02
Posts: 28

Re: Post your Clean URL .htaccess tweaks here

ZEUS SERVER

Being a very newbie (hello world) I thought it was all my fault for many days – no htaccess configurations seemed to help. Turned out the webhost, to whom the client is committed, uses Zeus and have it well locked down. After trying all the Zeus hints – http://forum.textpattern.com/viewtopic.php?id=3630 – I threatened to ditch the webhost.

That finally got me onto ‘elevated support’. After much pissing about they finally volunteered to write an access rule that would send all requests to index.php (except for requests for pages in /textpattern/ or /files/ or /images/).

So that got fixed, but other problems keep cropping up that I put down to Zeus glitches as noone else is talking about them. (ie messy URLs not working, only clean – which makes all category lists and internal hyperlinks misbehave – more on that elsewhere if I can figure it out).

Following is part of an email from the support that may be of use to others attempting to get TXP on Zeus.

“Content Negotation will not provide the solution you are looking for as we do not use mime types to differentiate php files from other files. Due to the way in which we setup our PHP environment, PHP has to be invoked by mapping specific file extensions to be parsed by PHP. As the system doesnt allow for a default handler we cannot facilitate your request via that method.

HTAccess rewrites are an Apache specfic function to mod_rewrite so do not work under our Zeus environment. Zeus provides a similar feature called rewrites but is not managabile via the htaccess file itself.

We are in the process of writting an interface to allow clients to manage this from a central point but currently this has to be done by hand by System Adminstrators. If you want to forward me the htaccess file provided by your CMS, I will convert the rules to Zeus format for you and implement server side.”

DIAGNOSTIC :

Textpattern version: 1.0rc3
Document root: /clientdata/www/au/x/xxxxx.com.au
$path_to_site: /clientdata/www/au/x/xxxxx.com.au
Textpattern path: /clientdata/www/au/x/xxxxx.com.au/textpattern
Permanent link mode: section_title
Temp folder: /www/clientweb/au/x/xxxxx.com.au/textpattern/tmp
Site URL: www.xxxxx.com.au
PHP version: 4.4.0
Register globals: 1
Magic quotes: 1/0
Locale: en_GB
Server: Zeus/4.3

.htaccess file contents:
————————————

————————————

Offline

#12 2005-09-23 12:04:08

mkorsakov
New Member
From: Dortmund
Registered: 2005-07-15
Posts: 5
Website

Re: Post your Clean URL .htaccess tweaks here

> lingsb wrote:
<blockquote>
.htaccess file contents: <pre><code>
<IfModule mod_rewrite.c> RewriteEngine On RewriteBase /

RewriteCond %{REQUEST_FILENAME} -f [OR] RewriteCond %{REQUEST_FILENAME} -d RewriteRule ^(.+) – [PT,L] RewriteRule ^(.*) index.php </IfModule> </code></pre> I think the main thing to be added to the default .htaccess should be ‘RewriteBase /’, otherwise it looks for the whole document root in the URL. The only advice needed is that if the .htaccess file and index.php file are in different directories, the RewriteBase should give the relative path of the directory containing index.php:

eg:<pre><code>
/.htaccess
/txp/index.php
</code></pre>
should have <code>‘RewriteBase /txp/’</code>
</blockquote>
Thanx a lot. This works with Textpattern 4 on an 1and1-Server:
<pre><code>RewriteEngine On
RewriteBase /

RewriteCond %{REQUEST_FILENAME} -f [OR]
RewriteCond %{REQUEST_FILENAME} -d
RewriteRule ^(.+) – [PT,L]

RewriteRule ^(.*) index.php</code></pre>

[mkorsakov]

Offline

#13 2005-09-25 07:35:49

ubernostrum
Member
From: Lawrence, KS
Registered: 2004-05-05
Posts: 238
Website

Re: Post your Clean URL .htaccess tweaks here

Just helped someone hosted at TextDrive with this one:

If you’re setting up Textpattern in a folder under your main ‘web’ or ‘public_html’ directory (which one you have depends on which server you’re on at TXD), and you want to access it as a subdomain (since TXD will map folders to subdomains for you), you need to add this in the .htaccess of the main domain:

RewriteEngine On
RewriteCond %{HTTP_HOST} ^your.sub.domain$ [NC]
RewriteRule ^(.*) subdomainfolder/index.php

After that, it works like a charm.


You cooin’ with my bird?

Offline

#14 2005-10-02 15:17:36

Sencer
Developer emeritus
From: cgn, de
Registered: 2004-03-23
Posts: 1,803
Website

Re: Post your Clean URL .htaccess tweaks here

> on hosteurope server.

.htaccess is a “feature” that is only supported for webpack L and larger at hosteurope (at least in germany). If you have a smaller webpack (like M) you can’t use .htaccess and thus currently can only use messy urls.

btw: This thread is meant for posting solutions, so that people can quickly scan for answers, rather than having to read through troubleshootings, questions, comments etc.

Offline

#15 2005-10-25 21:46:23

SamuelJohn
New Member
Registered: 2005-06-01
Posts: 8

Re: Post your Clean URL .htaccess tweaks here

I use a german provider (www.domainbox.de) and even phpinfo(); told me that mod_rewrite was ON, I always got 403 Errors when accessing any of my sites with the .htaccess. After writing an email to the support team, they activated mod_rewrite, and it is working with the .htacces fine now.

I just want to say, that phpinfo(); telling you mod_rewrite=on, might not mean that mod_rewrite is working properbly. The Apache was not configured to follow symlinks, the support wrote.

Now it’s woking fine.

Offline

#16 2005-10-26 02:13:53

jackson
Member
Registered: 2005-10-01
Posts: 14

Re: Post your Clean URL .htaccess tweaks here

This is not TXP specific, so hopefully it’s ok if I post it. I think it might be helpful to people in the future.

I was struggling with getting .htaccess working for TXP on my Debian Sarge box. The mod_rewrite module was loaded and everything seemed to be ok. Messy URL’s worked, but not clean.

After Googling for ages, I came across a comment at the bottom of this article at Debian Administration:

http://www.debian-administration.org/articles/136

The poster states that the problem is that the “AllowOverride” setting for the DocumentRoot directory as set forth in /etc/apache/httpd.conf should be changed from “None” to “All”. So, for example, that section of my httpd.conf file now looks like this:

=====

This should be changed to whatever you set DocumentRoot to.
{Directory /var/www}

This may also be “None”, “All”, or any combination of “Indexes”,
“Includes”, “FollowSymLinks”, “ExecCGI”, or “MultiViews”.
;
Note that “MultiViews” must be named explicitly —- “Options All”
doesn’t give it to you.
Options Indexes Includes FollowSymLinks MultiViews
This controls which options the .htaccess files in directories can
override. Can also be “All”, or any combination of “Options”, “FileInfo”,
“AuthConfig”, and “Limit”
AllowOverride All

Controls who can get stuff from this server.


;
Order allow,deny
Allow from all
{/Directory}
=====

(I changed the ‘#’ comment indicator to a ‘;’ since textile was parsing the ‘#’ as a numbered list and I also changed the <> brackets into {} since the former were being parsed as HTML).

Changing the AllowOverride from None to All fixed my problem and now clean URL’s work fine with the default TXP .htaccess. Hope this helps somebody.

Offline

#17 2005-10-30 23:44:06

xylpho
Member
From: Brest, France
Registered: 2005-10-24
Posts: 28

Re: Post your Clean URL .htaccess tweaks here

This controls which options the .htaccess files in directories can
override. Can also be “All”, or any combination of “Options”, “FileInfo”,
“AuthConfig”, and “Limit”
AllowOverride All

Changing this on my Mac (10.4.2) do the job. Great!!!


don’t eat yellow snow

Offline

Board footer

Powered by FluxBB