Textpattern CMS support forum

You are not logged in. Register | Login | Help

#11 2005-03-20 23:01:20

bb50014
Member
From: fiesole, italia
Registered: 2004-04-13
Posts: 15
Website

Re: [plugin] [ORPHAN] vdh_flickr

hmmm

-i got my key from flickr
-installed the plugin
-activated it
-created a section called ‘photogal’
-made a new article put the tag in the body (no title), then selected the section ‘photogal’
-publish’ed it
-went to my site “/photogal”

and got a blank page…

i’m using TP Rc3 rev224 hosted on texdrive…

… any ideas?

thanks in advance
brian

Offline

#12 2005-03-21 16:32:57

alicson
Member
Registered: 2004-05-26
Posts: 465
Website

Re: [plugin] [ORPHAN] vdh_flickr

‘am also hoping this might be reworked to work for RC3 soon… :)


textpattern.org :: find and share Textpattern resources
docs.textpattern.io :: Textpattern user documentation

Offline

#13 2005-03-21 16:44:06

larf
Plugin Author
Registered: 2005-01-31
Posts: 159
Website

Re: [plugin] [ORPHAN] vdh_flickr

@bb50014:
I wrote you an email, because I saw your email before I saw this forum post.

@alicson:
I’m on the latest subversion release and the plugin is working well. So please contact me so that we can get this going for you.

Offline

#14 2005-03-22 07:46:54

bb50014
Member
From: fiesole, italia
Registered: 2004-04-13
Posts: 15
Website

Re: [plugin] [ORPHAN] vdh_flickr

@alicson

i got it working on TXP rc3, i had to add a couple lines to my .htacess file so that i could serve up the pages with PHP 5, but jason wrote me saying that TD.one will be updated to 5 this week…

i did however have some issues using the plug from a subdirectory within my domain… that i’m trying to work through

i also noticed with RC3 that clean mode: section/id/title works the best, with /title i couldn’t call the section directly…

Offline

#15 2005-03-22 07:55:07

alicson
Member
Registered: 2004-05-26
Posts: 465
Website

Re: [plugin] [ORPHAN] vdh_flickr

thanks very much for thinking of me and providing that advice.
i should have posted back in here much earlier.. it did get solved..

Ralph was thoroughly courteous and might even consider adding a few new features to the next version of vdh_flickr;

since adding lines to my .htaccess file was breaking my site, i put a support ticket to textdrive and received me a reply a few minutes later that php5 was set to go for my domain, and all was well.

i did run into that section issue also… but once i figured out what the issue was, i’m pleased since my preference for clean url format is section/id/title/ anyway..

thank you again :)


textpattern.org :: find and share Textpattern resources
docs.textpattern.io :: Textpattern user documentation

Offline

#16 2005-03-22 08:05:01

larf
Plugin Author
Registered: 2005-01-31
Posts: 159
Website

Re: [plugin] [ORPHAN] vdh_flickr

@bb50014:
That’s right, the plugin does not work in a subdirectory. But I think I can get this resolved in the next version.

Offline

#17 2005-03-22 08:07:44

bb50014
Member
From: fiesole, italia
Registered: 2004-04-13
Posts: 15
Website

Re: [plugin] [ORPHAN] vdh_flickr

too funny my question was answered while i was typing it… RT!
thanks…

> bb50014 wrote:

> @alicson

the site you use the plug-in… is it in a sub-directory or at the pub level?

i still trying to figure out how to make it work from txp in a sub directory

ie: …/public_html/sub/textpattern

works fine if installed in the pub level

…/public_html/textpattern

also just curious do you have your .htacccess one level up from the txp directory our in the root level of the txp directory. i have mine one level/dir up.

.htaccess
/textpattern

anyways it’s a very cool little plug

Offline

#18 2005-03-22 16:39:59

larf
Plugin Author
Registered: 2005-01-31
Posts: 159
Website

Re: [plugin] [ORPHAN] vdh_flickr

I just released version 0.3.1 which does not have any features added, but should run in a subdirectory. So you guys can start playing with it…

When I tested the plugin with textpattern installed in a subdir, I used this .htaccess file:

RewriteBase /subdir/subsubdir
RewriteEngine On
RewriteCond %{REQUEST_FILENAME} -f [OR]
RewriteCond %{REQUEST_FILENAME} -d
RewriteRule ^(.+) – [PT,L]

RewriteRule ^(.*) index.php
AddDefaultCharset UTF-8

I guess the RewriteBase part might be important.

Offline

#19 2005-03-23 01:36:51

bb50014
Member
From: fiesole, italia
Registered: 2004-04-13
Posts: 15
Website

Re: [plugin] [ORPHAN] vdh_flickr

hi ralph

seems like the extra ‘Rewrite’ line in the .htaccess doesn’t work for me it re-directs the site to the Root ‘public_html’ version.

using the orig .htaccess and new plug-in 0.3.1 i get something like this in my sub-dir version (i can see the sets, but when i click on one i get this below)

…com/it/photogalphotogal/?set=175411
which just re-directs back to the index for the sub-directory…

where the english version with 0.3.0 is working

…com/photogal/?set=175411

thanks for working on a new version, looks like (non programmer speaking here) your getting close.

brian

> larf wrote:

> I just released version 0.3.1 which does not have any features added, but should run in a subdirectory. So you guys can start playing with it…

When I tested the plugin with textpattern installed in a subdir, I used this .htaccess file:

RewriteBase /subdir/subsubdir
RewriteEngine On
RewriteCond %{REQUEST_FILENAME} -f [OR]
RewriteCond %{REQUEST_FILENAME} -d
RewriteRule ^(.+) – [PT,L]

RewriteRule ^(.*) index.php
AddDefaultCharset UTF-8

I guess the RewriteBase part might be important.

Offline

#20 2005-03-23 10:28:44

larf
Plugin Author
Registered: 2005-01-31
Posts: 159
Website

Re: [plugin] [ORPHAN] vdh_flickr

That’s strange, it works perfect here.

> …com/it/photogalphotogal/?set=175411

And this looks like the plugin shows the correct path.

So I think this is related to the .htaccess files.
Only to be sure, you have one textpattern installation in “public_html”, and a second one in
“public_html/it”. If that is the case, there should be one .htaccess file in “public_html” with “RewriteBase /” in it, and there should be another .htaccess file in “public_html/it” which should have “RewriteBase /it” in it.
If that does not work, try to leave out the RewriteBase part first only in the “public_html” .htaccess file, then in both ones.

Offline

Board footer

Powered by FluxBB