Textpattern CMS support forum

You are not logged in. Register | Login | Help

#1 2019-02-25 15:25:54

Kossatsch
Member
From: St. Wolfgang
Registered: 2004-04-01
Posts: 198
Website

Updating (again)

When updating from 4.5.x to 4.7.2 I have a bunch of problems.

I had a set of websites running with the multisite install. When I wanted to update them to 4.7.1 I had some hassle, so I set my main HP to singlesite install and was able to get it to work again. Some days later I updated it to 4.7.2.

Now I wanted to update the rest of the sites (all with singlesite) directly to 4.7.2. But I get major problems with one page that has several plug-ins installed. I can enter the admin page, but then I get:

User_Error "Unknown character set: 'utf'"
in /www/htdocs/xxx/site_02/textpattern/lib/txplib_db.php at line 410.
textpattern/lib/txplib_misc.php:1759 adminErrorHandler()
updateErrorHandler()
textpattern/lib/txplib_db.php:410 trigger_error()
textpattern/lib/txplib_db.php:791 safe_query()
textpattern/update/_to_4.6.0.php:199 safe_create()
textpattern/update/_update.php:98 include()
textpattern/index.php:215 include()

Fatal error: Uncaught Exception: update failed in /www/htdocs/xxx/site_02/textpattern/lib/txplib_misc.php:1763 Stack trace: #0 [internal function]: updateErrorHandler(2, 'file_get_conten...', '/www/htdocs/xx...', 373, Array) #1 /www/htdocs/xxx/site_02/textpattern/vendors/Textpattern/L10n/Lang.php(373): file_get_contents('') #2 /www/htdocs/xxx/site_02/textpattern/vendors/Textpattern/L10n/Lang.php(401): Textpattern\L10n\Lang->getPack('de-de') #3 /www/htdocs/xxx/site_02/textpattern/update/_update.php(133): Textpattern\L10n\Lang->installFile('de-de') #4 /www/htdocs/xxx/site_02/textpattern/index.php(215): include('/www/htdocs/xx...') #5 {main} thrown in /www/htdocs/xxx/site_02/textpattern/lib/txplib_misc.php on line 1763

Is there any way to switch off the plug-ins?

I already tried this here, but I am unsure where to put it.

Any ideas?


txp at irox.de since spring 2004 (g1.17) & at roxomatic since 2006.

Offline

#2 2019-02-25 15:37:54

philwareham
Core designer
From: Farnham, Surrey, UK
Registered: 2009-06-11
Posts: 3,175
Website

Re: Updating (again)

Not related to the issue but worth noting, v4.7.3 should be out tomorrow.

Offline

#3 2019-02-25 15:42:53

colak
Admin
From: Cyprus
Registered: 2004-11-20
Posts: 7,170
Website

Re: Updating (again)

Hi Kossatsch,

You can disable all plugins using phpMyAdmin or similar. The enable/disable field should be under the txp_plugin table I think. I guess that the original db is not utf8 and that might be partially the problem for which you may use rvm_latin1_to_utf8.


Yiannis
——————————
neme.org | hblack.net | LABS | State Machines | Respbublika! | NeMe @ github

Offline

#4 2019-02-25 15:51:10

Bloke
Developer
From: Leeds, UK
Registered: 2006-01-29
Posts: 8,621
Website

Re: Updating (again)

Kossatsch wrote #316721:

When I wanted to update them to 4.7.1 I had some hassle

Depending on your version of MySQL, yes, 4.7.1 may have a few issues. 4.7.2 is more robust so jumping straight to that or 4.7.3 (as of tomorrow) is probably a smoother ride.

“Unknown character set: ‘utf’”

Very odd. Out of curiosity, what is the value of your dbcharset in config.php?

Is there any way to switch off the plug-ins?

If they’re in the database then go to phpMyAdmin (or equivalent) and set the status column to 0 for any plugins you want to disable.

If they are in the file system, just remove them from your plugin cache directory or rename them to something that does not end in .php.


The smd plugin menagerie — for when you need one more gribble of power from Textpattern. Bleeding-edge code available on GitHub.

Txp Builders – finely-crafted code, design and Txp

Offline

#5 2019-02-25 20:42:47

jakob
Admin
From: Germany
Registered: 2005-01-20
Posts: 3,396
Website

Re: Updating (again)

“Unknown character set: ‘utf’”

Yes, that should be utf8 or utf8mb4.

If you need a hand, send me an email (in German if you like) and I can see if I can help you out. If you want to get back to a multisite installation, I have some experience of that too with the revised setup.


TXP Builders – finely-crafted code, design and txp

Offline

#6 2019-03-10 10:23:16

Kossatsch
Member
From: St. Wolfgang
Registered: 2004-04-01
Posts: 198
Website

Re: Updating (again)

Thanks for your replies. This is weird, as I did not get any notifications, despite having e-mail notifications on.

In the meantime I closed the concerned website down, but there will be a whole bunch more of other websites (also from clients) where to implement an update, Maybe it would be good practice recommending to deactivate all plug-ins (or to do it automatically nby the update routine) and/or to be able to locate plugin tags (= non txp tags) in all sections, forms and articles.

Or is there already a plug-in for that?


txp at irox.de since spring 2004 (g1.17) & at roxomatic since 2006.

Offline

#7 2019-03-10 10:28:03

jakob
Admin
From: Germany
Registered: 2005-01-20
Posts: 3,396
Website

Re: Updating (again)

Never tried it myself but there’s wet_plugout that could help. It won’t update the plugins, though.

I don’t usually disable them all prior to an update, but do look whether the plugins are still necessary.


TXP Builders – finely-crafted code, design and txp

Offline

Board footer

Powered by FluxBB