Textpattern CMS support forum

You are not logged in. Register | Login | Help

#1 2018-12-30 11:16:02

sgw
Member
Registered: 2012-12-18
Posts: 56

4.6.2 - also "article not showing up"

I am quite a noob administering txp here … today I want(ed) to add some content and failed … copied an existing article … edited … no success.
Turned on debugging now and get this

Fehler im Tag: <txp:l10n_get_lang/> -> Textpattern Warning: Unbekannter Tag beim Verarbeiten des Bausteins header auf der Seitenvorlage default
textpattern/lib/txplib_publish.php:521 trigger_error()
textpattern/lib/txplib_publish.php:463 processTags()
textpattern/lib/txplib_misc.php:4415 parse()
textpattern/publish/taghandlers.php:487 parse_form()
output_form()
textpattern/vendors/Textpattern/Tag/Registry.php:83 call_user_func()
textpattern/lib/txplib_publish.php:514 Textpattern\Tag\Registry->process()
textpattern/lib/txplib_publish.php:463 processTags()
textpattern/lib/txplib_misc.php:4476 parse()
textpattern/publish.php:562 parse_page()
Fehler im Tag: <txp:l10n_lang_list /> -> Textpattern Warning: Unbekannter Tag beim Verarbeiten des Bausteins header auf der Seitenvorlage default
textpattern/lib/txplib_publish.php:521 trigger_error()
textpattern/lib/txplib_publish.php:463 processTags()
textpattern/lib/txplib_misc.php:4415 parse()
textpattern/publish/taghandlers.php:487 parse_form()
output_form()
textpattern/vendors/Textpattern/Tag/Registry.php:83 call_user_func()
textpattern/lib/txplib_publish.php:514 Textpattern\Tag\Registry->process()
textpattern/lib/txplib_publish.php:463 processTags()
textpattern/lib/txplib_misc.php:4476 parse()
textpattern/publish.php:562 parse_page()
Fehler im Tag: <txp:l10n_if_lang lang=“de-de”> -> Textpattern Warning: Unbekannter Tag beim Verarbeiten des Bausteins footer auf der Seitenvorlage default
textpattern/lib/txplib_publish.php:521 trigger_error()
textpattern/lib/txplib_publish.php:463 processTags()
textpattern/lib/txplib_misc.php:4415 parse()
textpattern/publish/taghandlers.php:487 parse_form()
output_form()
textpattern/vendors/Textpattern/Tag/Registry.php:83 call_user_func()
textpattern/lib/txplib_publish.php:514 Textpattern\Tag\Registry->process()
textpattern/lib/txplib_publish.php:463 processTags()
textpattern/lib/txplib_misc.php:4476 parse()
textpattern/publish.php:562 parse_page()

So I interpret this as something wrong in my default template?

looks like this:

<txp:output_form form="header" />

<div id="content" class="clearfix">

	<div class="section clearfix">
		<div id ="primary-content">

				<txp:article_custom category="Status" limit="1" status="live" form="status" />

			<div class="intro">

				<txp:article_custom category="Intro" limit="1" status="sticky" form="no_title" />
			</div>	
		</div> <!-- /primary-content -->

	<txp:output_form form="service_list" />
	</div> <!-- /section -->


	<div id="secondary-content">

		<div class="section clearfix">
			<txp:article_custom category="Features" form="features" limit="2" status="sticky" sort="ID" />
		</div> <!-- /section -->

		<div class="section clearfix">
			<div class="feature">
				<!--
<txp:linklist form="links" limit="4" sort="rand()"  label="Clients" labeltag="h3" wraptag="ul" class="rule" />
				<a href="?s=references">More ...</a>
-->
			</div>

			<div class="feature">
				<h3>Compliments</h3>
				<txp:article_custom category="Compliments" limit="1" form="compliments" sort="rand()" />
				<a href="?s=references">More ...</a>
			</div>
		</div> <!-- /section -->

	</div> <!-- /secondary-content -->
	</div> <!-- /content -->

<txp:output_form form="footer" />

For sure I consider upgrading to current stable, but I assume I should fix my templates etc first
Thanks for any help on this …

Offline

#2 2018-12-30 12:06:25

jakob
Moderator
From: Germany
Registered: 2005-01-20
Posts: 3,342
Website

Re: 4.6.2 - also "article not showing up"

These errors:

Fehler im Tag: <txp:l10n_get_lang/> -> Textpattern Warning: Unbekannter Tag beim Verarbeiten des Bausteins header auf der Seitenvorlage default
Fehler im Tag: <txp:l10n_lang_list /> -> Textpattern Warning: Unbekannter Tag beim Verarbeiten des Bausteins header auf der Seitenvorlage default
Fehler im Tag: <txp:l10n_if_lang lang=“de-de”> -> Textpattern Warning: Unbekannter Tag beim Verarbeiten des Bausteins footer auf der Seitenvorlage default

indicate that the error has to do with the MLP Multi-Lingual Publishing Plugin which appears not to be to activated. Those tags are in the header and footer forms (Bausteine) and have to do with the language switcher and which language is currently active. As it says it doesn’t recognise the tags, I suspect it’s not activated.

If you don’t need the language facilities any more, you can remove those tags (and possible closing tags). Otherwise please activate the MLP Plugin(s) and if you get errors with that, see the MLP thread linked above.


TXP Builders – finely-crafted code, design and txp

Offline

#3 2018-12-30 14:17:40

sgw
Member
Registered: 2012-12-18
Posts: 56

Re: 4.6.2 - also "article not showing up"

You are correct: MLP was disabled (back then at the upgrade I was happy to get things working without MLP first and never re-enabled it).

It seems that the content created in the meantime now misses something, I don’t see several articles under “Renditions” and currently can’t change their language either (all English per default, I need german and english here). So I assume I have to recreate some pages or add some meta-data somewhere?

thanks, Stefan

correction: I see the articles under “Renditions”, but not under “MLP”.

Last edited by sgw (2018-12-30 14:24:46)

Offline

#4 2018-12-30 15:12:12

jakob
Moderator
From: Germany
Registered: 2005-01-20
Posts: 3,342
Website

Re: 4.6.2 - also "article not showing up"

I’m afraid I know very little about MLP. You’ll need to check the MLP thread – note the new location of the plugin at GitHub at the top of the thread – to find out the state of the most recent version and compatibility.


TXP Builders – finely-crafted code, design and txp

Offline

#5 2018-12-30 16:20:22

sgw
Member
Registered: 2012-12-18
Posts: 56

Re: 4.6.2 - also "article not showing up"

That MLP thread looks inactive to me: last posting from August.
I will try my way … I assume there is no more recent way of doing multi-lingual txp?

Offline

Board footer

Powered by FluxBB