Textpattern CMS support forum

You are not logged in. Register | Login | Help

#1 2018-10-11 13:16:07

philwareham
Core designer
From: Farnham, Surrey, UK
Registered: 2009-06-11
Posts: 3,060
Website

[Solved] Updating from an old 4.6.0-dev install - errors at login

Hi. I’m trying to update the Txstyle.org website that we’ve been handed, from its current 4.6.0-dev (quite an old dev snapshot) to 4.7.1, and I’m getting the following error message at login:

User_Error "Invalid default value for 'posted'"
in /Users/pwareham/Sites/textile-lang-com-website/public/textpattern/lib/txplib_db.php at line 410.

Any ideas on how I can fix this up so we can start modernising the site? Thanks!

Offline

#2 2018-10-11 13:42:33

michaelkpate
Moderator
From: Avon Park, FL
Registered: 2004-02-24
Posts: 1,111
Website

Re: [Solved] Updating from an old 4.6.0-dev install - errors at login

There are several past discussions but I didn’t see an exact answer.

Offline

#3 2018-10-11 14:14:55

uli
Moderator
From: Cologne
Registered: 2006-08-15
Posts: 4,134

Re: [Solved] Updating from an old 4.6.0-dev install - errors at login

There’s been a discussion on that recently:
forum.textpattern.io/viewtopic.php?id=49048 that seemed to have this solution.


In bad weather I never leave home without wet_plugout, smd_where_used and adi_form_links

Offline

#4 2018-10-11 14:20:15

etc
Developer
Registered: 2010-11-11
Posts: 2,833
Website

Re: [Solved] Updating from an old 4.6.0-dev install - errors at login

uli wrote #314545:

There’s been a discussion on that recently:
forum.textpattern.io/viewtopic.php?id=49048 that seemed to have this solution.

Nope, that didn’t work. You can try to

  • downgrade to some pre-5.7 SQL version
  • update txp
  • upgrade SQL again

No guarantee, though.


etc_[ query | search | pagination | date | tree | cache ]

Offline

#5 2018-10-11 16:30:25

philwareham
Core designer
From: Farnham, Surrey, UK
Registered: 2009-06-11
Posts: 3,060
Website

Re: [Solved] Updating from an old 4.6.0-dev install - errors at login

etc wrote #314546:

Nope, that didn’t work. You can try to

  • downgrade to some pre-5.7 SQL version
  • update txp
  • upgrade SQL again

Yep, that worked a treat thanks. I downgraded to MAMP 4.x (which runs mySQL 5.6), then installed my database backup of the site, updated Textpattern to 4.7.1 and then updated MAMP to 5.x again (which runs mySQL 5.7). Now got the site upgraded to 4.7.1 without problem.

FYI here’s how to downgrade MAMP Pro to v4 if it’s of use to anyone in future.

Offline

Board footer

Powered by FluxBB