Textpattern CMS support forum

You are not logged in. Register | Login | Help

#1 2017-06-30 05:36:38

solocorps
New Member
Registered: 2017-06-30
Posts: 6

[SOLVED] "Form can't be submitted" error when trying to embed media

For months, I’ve been able to embed YouTube videos and audio files in my posts when I was running Textpattern 4.5.5.

Suddenly, a couple of weeks ago, I started getting the “Sorry, the form could not be submitted. Please try again later.” error when trying to save an edit that includes the <iframe> code.

Once I removed the code, I could save fine.

All of my archival articles that contain the code are still working just fine. But I can’t create any new articles with the code.

I thought this might be an issue with an older version, so I’ve upgraded to 4.6.2, and I’m having the same difficulty.

Is it possible this is an issue with my host?

Any other ideas?

Appreciate any help, folks.

Offline

#2 2017-06-30 07:12:52

colak
Admin
From: Cyprus
Registered: 2004-11-20
Posts: 7,107
Website

Re: [SOLVED] "Form can't be submitted" error when trying to embed media

Hi solocorps and welcome to the forum.

You should upgrade to textpattern 4.6.2 if your server specs allow it.

If you do so, you could try to use a plugin?

If you wish to stay on the 4.5.5 version you could go with arc_youtube


Yiannis
——————————
neme.org | hblack.net | LABS | State Machines | NeMe @ github

Offline

#3 2017-06-30 09:23:38

etc
Developer
Registered: 2010-11-11
Posts: 3,106
Website

Re: [SOLVED] "Form can't be submitted" error when trying to embed media

If it has stopped working all of a sudden, I would check the host security settings.


etc_[ query | search | pagination | date | tree | cache ]

Offline

#4 2017-06-30 13:43:24

solocorps
New Member
Registered: 2017-06-30
Posts: 6

Re: [SOLVED] "Form can't be submitted" error when trying to embed media

Thanks, Yiannis. I upgraded to 4.6.2. Problem persists.

etc, it was a sudden change. Host security settings are not within Textpattern settings are they? Those would be configured through my provider?

Offline

#5 2017-06-30 14:06:31

etc
Developer
Registered: 2010-11-11
Posts: 3,106
Website

Re: [SOLVED] "Form can't be submitted" error when trying to embed media

solocorps wrote #306121:

etc, it was a sudden change. Host security settings are not within Textpattern settings are they? Those would be configured through my provider?

It’s possible that your provider does not let you POST <iframe /> elements. To check, put this in some article:

notextile. <<txp:php>echo 'iframe';</txp:php> src="https://www.youtube.com/embed/X8xzfU2zcVI?feature=oembed" />

If it works, then I would say yes, ask your provider.


etc_[ query | search | pagination | date | tree | cache ]

Offline

#6 2017-06-30 14:09:05

solocorps
New Member
Registered: 2017-06-30
Posts: 6

Re: [SOLVED] "Form can't be submitted" error when trying to embed media

Thanks, etc.

I have articles from before that use iframe tags and they are working fine.

I just tried the “notextile” snippet and it returned the same error:
Sorry, the form could not be submitted. Please try again later.

Offline

#7 2017-06-30 14:14:42

etc
Developer
Registered: 2010-11-11
Posts: 3,106
Website

Re: [SOLVED] "Form can't be submitted" error when trying to embed media

Have you tried to resave an existing item containing <iframe />? Or even just iframe (not a tag)?


etc_[ query | search | pagination | date | tree | cache ]

Offline

#8 2017-06-30 14:21:46

solocorps
New Member
Registered: 2017-06-30
Posts: 6

Re: [SOLVED] "Form can't be submitted" error when trying to embed media

Thanks for your continued help, etc.

1. I am not able to edit articles that include the <iframe> tag; when I try to save the older article I get the error.

2. I am able to save an article with a YouTube URL.

3. I am able to save an article with the word “iframe”.

Offline

#9 2017-06-30 14:33:27

colak
Admin
From: Cyprus
Registered: 2004-11-20
Posts: 7,107
Website

Re: [SOLVED] "Form can't be submitted" error when trying to embed media

Hi solocorps,

Did you install the oui_player plugin?

With that all you will need to add is:

<txp:oui_player provider="youtube" play="https://www.youtube.com/watch?v=w-I6XTVZXww" />

Yiannis
——————————
neme.org | hblack.net | LABS | State Machines | NeMe @ github

Offline

#10 2017-06-30 14:39:49

colak
Admin
From: Cyprus
Registered: 2004-11-20
Posts: 7,107
Website

Re: [SOLVED] "Form can't be submitted" error when trying to embed media

Not recommended but in your htaccess file you can add:

<IfModule mod_security.c>
SecFilterEngine Off
SecFilterScanPOST Off
</IfModule>  

If the problem goes away, you should contact your hosting provider to filter posts like that in their global mod_security


Yiannis
——————————
neme.org | hblack.net | LABS | State Machines | NeMe @ github

Offline

Board footer

Powered by FluxBB