Textpattern CMS support forum

You are not logged in. Register | Login | Help

#1 2011-02-08 20:49:16

Mats
Member
From: Sweden
Registered: 2011-01-16
Posts: 30
Website

[sv-se] ÅÄÖ fungerar inte vid sortering på artikellistor [Löst]

Hej!

Jag har lagt till en post om detta i “How Do I?”-avdelningen men jag chansar här också. När jag försöker sortera en artikellista så vill TXP lägga Å före A, vilket inte är så lyckat.

Jag har hittat ett par trådar som berör ämnet men tyvärr har jag inte lyckats lösa problemet.

[Edit] Det här verkar vara problemet:

http://sgehrig.wordpress.com/2008/09/24/on-how-to-sort-an-array-of-utf-8-strings/

[Edit 2]

För att sorteringen ska fungera måste utf8_swedish_ci användas i databasen.
Tack till Uli som löste problemet!

Tacksam för råd!

/Mats

Last edited by Mats (2011-02-09 07:15:40)

Offline

#2 2014-07-06 11:48:35

superduper
New Member
Registered: 2014-07-04
Posts: 1

Re: [sv-se] ÅÄÖ fungerar inte vid sortering på artikellistor [Löst]

Hej. Skulle du kunna lägga ut någon sort stegvis tutorial. Vore jätte snällt då jag suttit med detta i ett par dagar och ej löst ännu.
alla mina ÅÄÖ hamnar först i sorteringen. vill ju såklart ha dem sist.

Skönt när man ser steg-för-steg lösning. (då missar man oftast inget)

Skulle vara jätte tacksamt!

Last edited by superduper (2014-07-06 11:49:40)

Offline

#3 2014-07-07 20:13:57

uli
Moderator
From: Cologne
Registered: 2006-08-15
Posts: 4,191

Re: [sv-se] ÅÄÖ fungerar inte vid sortering på artikellistor [Löst]

Hi superduper, welcome to the forum!

Here’s how you do it in phpMyAdmin:
Find out the number of the custom field you want to edit. Switch over to phpMyAdmin, choose your database and select the textpattern table (which might have a prefix). Next, click the “Structure” tab if it’s not yet active, tick the checkbox of your custom field and click the pen icon underneath the table.
In the following window/pop-up select “utf8_swedish_ci” from the drop-down menu in the collation column. Click “Save”, and your articles should sort OK from now on.


In bad weather I never leave home without wet_plugout, smd_where_used and adi_form_links

Offline

Board footer

Powered by FluxBB