Textpattern CMS support forum

You are not logged in. Register | Login | Help

#1 2008-10-28 11:24:21

Jack
Member
Registered: 2005-10-10
Posts: 14

upgrade woes

I have a textpattern site that I made a few years ago (might have been 4.0.1) and I recently decided to upgrade.

there’s a few kinks in the site now that I can’t seem to figure out:

including php files? When I try to include a php file in an article this is what I see:
http://sfu.ewb.ca/index.php?id=36

this is the article:

<txp:php>
include(“execlist.php”);
</txp:php>

oddly enough the includes in the template work fine.

also, there’s a “<” appended to the end of every article (like this: http://sfu.ewb.ca). Not that big a deal, but it breaks my html validation..

any ideas?

edit:

come to think of it, the two problems seem to be linked. I think the php error will go away if the “<” thing is removed.

Last edited by Jack (2008-10-28 11:28:11)

Offline

#2 2008-10-28 17:09:12

Els
Admin
From: The Netherlands
Registered: 2004-06-06
Posts: 7,458

Re: upgrade woes

There is a setting in Advanced preferences: ‘Allow PHP in articles?’ Make sure it is set to ‘yes’. That will probably get rid of the < as well.

Offline

#3 2008-10-28 19:44:30

Jack
Member
Registered: 2005-10-10
Posts: 14

Re: upgrade woes

hm.. it’s turned on.

I don’t think it’s a bug, probably the upgrade broke something.

Last edited by Jack (2008-10-28 20:00:12)

Offline

#4 2008-10-28 22:21:22

Els
Admin
From: The Netherlands
Registered: 2004-06-06
Posts: 7,458

Re: upgrade woes

Did you check the tag trace (switch to debugging mode)? You can also post it here so we can have a look.

Offline

Board footer

Powered by FluxBB