Textpattern CMS support forum

You are not logged in. Register | Login | Help

#1 2008-07-27 23:20:04

bobsr85
New Member
Registered: 2008-07-27
Posts: 4

Config.php problem on installation

Config.php problem…during installation when I get to the part where I need to add the generated text into the config.php file, it will not work. When I click on “I Did It”, nothing happens. It will not go to the next screen.

Have read and tried everything I can think of, including re-doing the MySQL database.

Bob

Offline

#2 2008-07-28 00:59:07

uli
Moderator
From: Cologne
Registered: 2006-08-15
Posts: 4,179

Re: Config.php problem on installation

Try using “DOS linebreaks”, document encoding “Western (Windows Latin 1)”, one of these did the trick for me.


In bad weather I never leave home without wet_plugout, smd_where_used and adi_form_links

Offline

#3 2008-07-28 05:26:08

colak
Admin
From: Cyprus
Registered: 2004-11-20
Posts: 7,103
Website

Re: Config.php problem on installation

Did you rename the config.php file?


Yiannis
——————————
neme.org | hblack.net | LABS | State Machines | NeMe @ github

Offline

#4 2008-07-28 12:17:00

ruud
Developer emeritus
From: a galaxy far far away
Registered: 2006-06-04
Posts: 5,068
Website

Re: Config.php problem on installation

What is the name of the file you put it in and where is that file stored relative to the root directory of your textpattern based website?

Offline

#5 2008-07-28 15:06:16

bobsr85
New Member
Registered: 2008-07-27
Posts: 4

Re: Config.php problem on installation

1) Yes…changed config-dist.php to config.php after I put the script into it.

2) I put it into a file called /blog/ in the root directory of the server.

ie: public_htm/domain/blog/textpattern/

Offline

#6 2008-07-28 15:12:05

ruud
Developer emeritus
From: a galaxy far far away
Registered: 2006-06-04
Posts: 5,068
Website

Re: Config.php problem on installation

The config.php file should be located at public_html/domain/blog/textpattern/config.php

Offline

#7 2008-07-28 15:24:01

bobsr85
New Member
Registered: 2008-07-27
Posts: 4

Re: Config.php problem on installation

Yes…it is in the /textpattern/ directory.

Offline

#8 2008-07-28 16:16:58

ruud
Developer emeritus
From: a galaxy far far away
Registered: 2006-06-04
Posts: 5,068
Website

Re: Config.php problem on installation

Can you provide the URL for your website?
What happens if you visit www.yourdomain.com/blog/textpattern/setup in your browser with config.php already stored in the correct location? It should abort the installation (telling you config.php already exists) after you choose a language. If it doesn’t do that. Either the permissions on config.php are incorrect or it’s got the wrong name or the wrong location.

Offline

#9 2008-08-07 02:35:51

UncleVinny
New Member
Registered: 2008-08-07
Posts: 9

Re: Config.php problem on installation

I am having the exact same problem, so I will follow this thread to see if it ever gets resolved.
When I do the above (what RUUD) suggested, I get:
Looks like Textpattern is already installed. If you want to make a clean install . . .

But I never get screen 5 in the instructions, where they ask you to
create a new user ID.

Wish us luck.

Offline

#10 2008-08-07 10:47:25

uli
Moderator
From: Cologne
Registered: 2006-08-15
Posts: 4,179

Re: Config.php problem on installation

Delineating some more detail would be helpful.

If you don’t get the user registration screen, it sounds like everything else worked OK so far, so you don’t have “the exact same problem”?


In bad weather I never leave home without wet_plugout, smd_where_used and adi_form_links

Offline

Board footer

Powered by FluxBB