Textpattern CMS support forum

You are not logged in. Register | Login | Help

#1 2008-02-02 22:34:52

ruud
Developer emeritus
From: a galaxy far far away
Registered: 2006-06-04
Posts: 5,057
Website

Feedback on the Textpattern 4.0.6 release

Release announcement on the weblog:
http://textpattern.com/weblog/310/textpattern-406-released

If you have run into trouble with upgrading or installing, please create a new topic in the appropriate place.

———————————————————————————————————————-

Plugins that require updates:

  • asy_jpcache: needs add_privs('asy_jpcache');
  • asy_sitemap: needs add_privs('asy_sitemap');
  • rss_db_admin_manager: needs add_privs('rss_db_man'); add_privs('rss_sql_run'); add_privs('rss_db_bk'); (more info)
  • glz_custom_fields: upgrade to the soon to be released version 1.1
  • bab_newsletter: needs add_privs? latest version looks okay
  • stm_image_uploader: upgrade to version 0.4
  • fpx_image_import: needs add_privs('fpxii');
  • mem_self_register: upgrade to version 0.9 (requires mem_form)

If other plugins break in 4.0.6, post them in this topic and describe the problem

Fixing admin-side plugins that loose an (extension) tab after the 4.0.6 upgrade:
For the plugins listed above as needing add_privs, edit the plugin, look for the bit of code that looks like:

if (@txpinterface == 'admin') {
  register_tab("extensions", "event", "tab name");
}

And change it to (of course, replace ‘event’ with whatever it is called in the plugin):

if (@txpinterface == 'admin') {
  add_privs('event', '1');
  register_tab("extensions", "event", "tab name");
}

Last edited by ruud (2008-02-03 11:02:21)

Offline

#2 2008-02-02 23:19:11

squaredeye
Member
From: Greenville, SC
Registered: 2005-07-31
Posts: 1,495
Website

Re: Feedback on the Textpattern 4.0.6 release

Congrats Devs!
Well done.

Matthew


Offline

#3 2008-02-03 00:32:00

lee
Member
From: Normandy, France
Registered: 2004-06-17
Posts: 831

Re: Feedback on the Textpattern 4.0.6 release

Many thanks for all your hard work devs, it’s very much appreciated.

Last edited by lee (2008-02-03 00:35:23)

Offline

#4 2008-02-03 01:31:36

maverick
Member
From: Southeastern Michigan, USA
Registered: 2005-01-14
Posts: 957
Website

Re: Feedback on the Textpattern 4.0.6 release

+1 on the thanks

Mike

Offline

#5 2008-02-03 01:46:29

Els
Admin
From: The Netherlands
Registered: 2004-06-06
Posts: 7,456

Re: Feedback on the Textpattern 4.0.6 release

Thank you :)
(So far upgraded 5 sites, 3 of which were still on 4.0.4, no problems at all!)

Offline

#6 2008-02-03 03:26:26

jdykast
Member
From: Tennessee
Registered: 2004-12-30
Posts: 119
Website

Re: Feedback on the Textpattern 4.0.6 release

Much thanks for the effort, hard work and patience!

Offline

#7 2008-02-03 07:41:57

Dragondz
Moderator
From: Algérie
Registered: 2005-06-12
Posts: 1,264
Website

Re: Feedback on the Textpattern 4.0.6 release

Thanks for this wonderful job devs!

I had installed SVN snapshot for one site (in developpment), now i upgraded it to official release!

When it s done i connected to admin side, I got directly to write page (before when i upgrade a site i got admin prefs tab!), when i see diagnostic tab here is te messages :

mysql_table_errors:
textpattern: error: Table upgrade required. Please do "REPAIR TABLE `textpattern`" to fix it!,
txp_category: error: Table upgrade required. Please do "REPAIR TABLE `txp_category`" to fix it!,
txp_css: error: Table upgrade required. Please do "REPAIR TABLE `txp_css`" to fix it!,
txp_discuss: error: Table upgrade required. Please do "REPAIR TABLE `txp_discuss`" to fix it!,
txp_discuss_ipban: error: Table upgrade required. Please do "REPAIR TABLE `txp_discuss_ipban`" to fix it!,
txp_discuss_nonce: error: Table upgrade required. Please do "REPAIR TABLE `txp_discuss_nonce`" to fix it!,
txp_file: error: Table upgrade required. Please do "REPAIR TABLE `txp_file`" to fix it!,
txp_form: error: Table upgrade required. Please do "REPAIR TABLE `txp_form`" to fix it!,
txp_image: error: Table upgrade required. Please do "REPAIR TABLE `txp_image`" to fix it!,
txp_lang: error: Table upgrade required. Please do "REPAIR TABLE `txp_lang`" to fix it!,
txp_link: error: Table upgrade required. Please do "REPAIR TABLE `txp_link`" to fix it!,
txp_log: error: Table upgrade required. Please do "REPAIR TABLE `txp_log`" to fix it!,
txp_page: error: Table upgrade required. Please do "REPAIR TABLE `txp_page`" to fix it!,
txp_plugin: error: Table upgrade required. Please do "REPAIR TABLE `txp_plugin`" to fix it!,
txp_prefs: error: Table upgrade required. Please do "REPAIR TABLE `txp_prefs`" to fix it!,
txp_section: error: Table upgrade required. Please do "REPAIR TABLE `txp_section`" to fix it!,
txp_users: error: Table upgrade required. Please do "REPAIR TABLE `txp_users`" to fix it!

I have these plugins installed:

asy_wondertag
chh_article_lib
chh_if_data
chh_related_articles
chs_if_urlvar
hak_article_image
rss_admin_show_adv_opts
rss_auto_excerpt
upm_image
upm_img_popper
upm_insert_tab
zem_contact_lang
zem_contact_reborn

I have also :MySQL: 5.0.45-community, Version de PHP: 5.2.5, Bibliothèque GD: bundled (2.0.34 compatible) formats supportés : GIF, JPG, PNG.

I will try repair table to see if that solve the pb!

NB: Ok the repare table solve the error messages! all seems to be OK

NB2: I updated another website in the same situation as le previous except that it has no plugins, and I had the same error message, repear table also solved the pb! I think it s maybe pb with mysql5?, wait other people to see if it s that or no

News: I updated another website (4.0.4) to this release and got the same error message! then maybe it s an issue with mysql5.0.45 or php 5..2.5? And in this website I had an error message from upm_date_archive (0.2.1), but the message desapeared after refrsh tab (the message was about duplicate entry) and all seems workink ok!

Last edited by Dragondz (2008-02-03 08:57:06)

Offline

#8 2008-02-03 09:13:28

jstubbs
Moderator
From: Hong Kong
Registered: 2004-12-13
Posts: 2,389
Website

Re: Feedback on the Textpattern 4.0.6 release

Thanks for this release developers! Got this error when logging in after updating to 4.06 from 4.05:

A problem occured while loading the plugin: upm_image -> User_Warning: Duplicate entry '1-upm_image_load_script' for key 1
insert into txp_prefs set

Also – what is the correct code for upgrading rss_db_admin_manager? Its not clear from the first post…

[Ruud: I think it’s best to ask this in the author support topic for those plugins. That way, the author knows an update is needed and it’s probably the first place others will look who have the same question]

Last edited by ruud (2008-02-03 10:41:59)

Offline

#9 2008-02-03 09:25:31

Pat64
Plugin Author
From: France
Registered: 2005-12-12
Posts: 1,157
Website

Re: Feedback on the Textpattern 4.0.6 release

Tks to our prefered Devs :)
I’m going to try a local update and send my feed back later.

Best regards,

:)


Patrick.
Txp Tricks & Tips by french users : http://txp-fr.net | G+
Github

Offline

#10 2008-02-03 10:45:30

Vitruvius
Plugin Author
Registered: 2004-09-21
Posts: 119

Re: Feedback on the Textpattern 4.0.6 release

Just a quick note from a heavy TXP user (who is pretty quite on the forums): Thank you!

I’ve yet to upgrade any of my sites – but I’ll do so this week.

SH

Offline

Board footer

Powered by FluxBB