Textpattern CMS support forum

You are not logged in. Register | Login | Help

#1 2006-10-03 17:16:28

alittle116
Member
From: Brooklyn
Registered: 2005-09-14
Posts: 72
Website

why are my article categories not working??

this site is still heavily under construction and currently is only tested for FireFox on a PC

http://www.diskoweb.com/thedeadshark/index.php?s=Live-Feed

Anyways, you will notice that the category links (either in the article itself or in the menu on the right) are not doing anything on this particular page. These categories ONLY apply to the section called “Live Feed”.

Any idea why these are not working?

  • I realize that the links under each article and the links in the menu are pointing to different URLs, but regardles neither of them work

Last edited by alittle116 (2006-10-03 17:23:26)

Offline

#2 2006-10-03 21:12:34

Els
Admin
From: The Netherlands
Registered: 2004-06-06
Posts: 7,458

Re: why are my article categories not working??

Can you show us what the article tag on your ‘Live Feed’ page looks like?

Offline

#3 2006-10-03 21:13:48

alittle116
Member
From: Brooklyn
Registered: 2005-09-14
Posts: 72
Website

Re: why are my article categories not working??

on the “Live Feed” page:

<code><txp:article_custom form=“default_liveFeedFull” section=“Live-Feed” /></code>

Offline

#4 2006-10-03 21:17:09

Els
Admin
From: The Netherlands
Registered: 2004-06-06
Posts: 7,458

Re: why are my article categories not working??

There’s the problem. <txp:article_custom /> is not context sensitive, so it doesn’t ‘know’ we’re on a category page. If you just change it to <txp:article form="default_liveFeedFull" /> the tag will recognize the section as well as the category that is requested.

Offline

#5 2006-10-03 21:20:47

alittle116
Member
From: Brooklyn
Registered: 2005-09-14
Posts: 72
Website

Re: why are my article categories not working??

thanks, that works!

i have a related question. i want to also have a menu of months underneath the categories. how can i filter the articles by month? do i have to hardcode each month in the menu?

Offline

#6 2006-10-03 21:33:22

Els
Admin
From: The Netherlands
Registered: 2004-06-06
Posts: 7,458

Re: why are my article categories not working??

Offline

Board footer

Powered by FluxBB