Textpattern CMS support forum

You are not logged in. Register | Login | Help

#41 2006-01-18 18:09:12

hakjoon
Moderator
From: Arlington, VA
Registered: 2004-07-29
Posts: 1,633
Website

Re: hak_tinymce WYSIWYG article editor

Lee above mentioned the same problem but I never got any more info from him to troubleshoot it. I’ve still been unable to replicate it so I don’t know what causes it.

Any chance you could post the page source up somewhere? That way I can see if it’s something being called inproperly or something. Are you running any other plugins in the write tab?


Shoving is the answer – pusher robot

Offline

#42 2006-01-18 18:12:37

lee
Member
From: Normandy, France
Registered: 2004-06-17
Posts: 831

Re: hak_tinymce WYSIWYG article editor

I had the same problem, but when I went back to the site yesterday, after changing nothing, it started working!

Offline

#43 2006-01-18 18:14:06

hakjoon
Moderator
From: Arlington, VA
Registered: 2004-07-29
Posts: 1,633
Website

Re: hak_tinymce WYSIWYG article editor

I’m trying to see if I can find some info from the moxiecode forums on this but so far no luck. I’m glad you got it working.

Also please let me know what browsers this is happening on. Specially if it works on one and not another.

Last edited by hakjoon (2006-01-18 18:19:42)


Shoving is the answer – pusher robot

Offline

#44 2006-02-01 19:30:55

mrdale
Moderator
From: Walla Walla
Registered: 2004-11-19
Posts: 2,202
Website

Re: hak_tinymce WYSIWYG article editor

Any more thoughts on bending this plugin to work in the excerpt field too? It would be nice to not require users to learn textile or HTML just for the excerpt.

BTW: I know you are working on a lot of stuff mrJoon. Don’t want to be annoying, just curious.

Offline

#45 2006-02-01 19:55:58

hakjoon
Moderator
From: Arlington, VA
Registered: 2004-07-29
Posts: 1,633
Website

Re: hak_tinymce WYSIWYG article editor

I actually have this pretty much working. I’m just trying to incorporate tinyfly’s request for no editor for an article originally created with textile and then it’s out.

I’m hoping by this weekend, actually I might release it this weekend either way since the excerpt functionality is working already. I ended up having 2 checkboxes for the editor excerpt and article. That seemed like the best way to accomodate all the options without a bunch of logic gymnastics.

My workload at work is easing up so I’m hoping to have some more time to work on TXP.

Last edited by hakjoon (2006-02-01 19:56:59)


Shoving is the answer – pusher robot

Offline

#46 2006-02-01 19:59:52

mrdale
Moderator
From: Walla Walla
Registered: 2004-11-19
Posts: 2,202
Website

Re: hak_tinymce WYSIWYG article editor

mad props DrJ.

Offline

#47 2006-02-07 00:22:38

hakjoon
Moderator
From: Arlington, VA
Registered: 2004-07-29
Posts: 1,633
Website

Re: hak_tinymce WYSIWYG article editor

Version 0.5.3 released.

highlights

  • Tinymce updated to version 2.0.2.
  • Editor now works on excerpts, with individual toggles for the article and the excerpt.
  • New admin panel with options for editor toggle behavior.

Last edited by hakjoon (2006-02-07 14:33:54)


Shoving is the answer – pusher robot

Offline

#48 2006-02-07 03:29:39

mrdale
Moderator
From: Walla Walla
Registered: 2004-11-19
Posts: 2,202
Website

Re: hak_tinymce WYSIWYG article editor

You’re a busy man mr.joon thanks for the excerpts thing.

Offline

#49 2006-02-07 14:35:49

hakjoon
Moderator
From: Arlington, VA
Registered: 2004-07-29
Posts: 1,633
Website

Re: hak_tinymce WYSIWYG article editor

The textpattern parts of the interface are also translatable now and are cued off the selected language used for the interface. Currently only en-us but if anyone is interested in providing translations into other languages I will include them


Shoving is the answer – pusher robot

Offline

#50 2006-02-08 02:57:37

simonbarne
New Member
From: Jakarta, Indonesia
Registered: 2006-02-07
Posts: 3

Re: hak_tinymce WYSIWYG article editor

When I reopen an existing article, the plain text appears momentarily then vanishes when the WYSIWYG editor panel appears. Even if I toggle editor back, the text area is now blank – the article text is lost.

It doesn’t seem to make any difference whether the article was originally created as plain text or with Textile or in the WYSIWYG editor. Nor does changing the preference ‘Use Textile’ or ‘Leave text untouched’ have any effect.

I’m probably being dim, but does anyone have any ideas?

Offline

Board footer

Powered by FluxBB